Note

There exists a newer version of this page and the content below may be outdated. See https://quodlibet.readthedocs.org/en/latest for the latest documentation.

Requirements

Core Dependencies

Quod Libet depends on the Python runtime and associated libraries.

Particular audio formats depend on various GStreamer decoding elements, as well as other Python modules. GStreamer splits their downlads into ‘’good’‘, ‘’bad’‘, ‘’ugly’‘, and ‘’ffmpeg’‘ packages, each of which contains elements; you probably want them all.

Additional Features

Audio Feed support depends on HTTP support and Universal Feed Parser.

Many parts of Quod Libet benefit from D-Bus and its Python bindings.

iPod support depends on libgpod.

Device support depends on UDisks 1.

Plugins

Part of Quod Libet’s strength is in its rich array of plugins to extend the base functionality and interface with other systems. Some of these depend on libraries of their own. If you don’t have these, the plugin manager will catch these errors and disable the plugin to avoid errors in QL itself, and present them in the plugins error section. Once you’ve installed the libraries, the plugins should work as expected.

Some notable examples: